Wednesday, March 01, 2017

Conkywx SIX release

Now Conkywx is SIX - Additions and changes:
  • Use conky version 1.10x - though will work with conky 1.9x as well. Note that templates for 1.9x version are included but not supported.
  • If you are using Arch Linux - it is strongly recommended to use conky_cairo and tolua++_5.3 - both in AUR and will connect with lua 5.3 - better and faster than lua 5.1
  • Day and Night movement of the Sun and the Moon
  • Calendar
  • Smooth scroller - lua widget which enables smooth scrolling of text in up, down, left, right and bounce (hits left edge and starts going right and vice versa)
  • GDACS - Global Disaster Alert and Coordination System
  • View latest News from any news service that has a RSS feed
  • Most short comings of this version of conky are handled using lua scripts
  • conky_startup - this handles the startup issues - if your update interval is 5 seconds - conky updates that conky config in 5 * 2 seconds [10 seconds ] - so we update it such that your conky starts like on steroids
  • conky_pre_exec - this handles anything that needs to be done only ONCE - or unless updated manually - same as 1.9x
  • conky_if_running - checks the pidof the required process - same as 1.9x
  • Earth quake/ Seismic has new options to set Alarms that will show up alarms via the conkywx system, the location in question also flashes in the Seismic display
  • Seconday PWS for xml_ID - when the primary stops or has stale data.
  • Some forecast handling changes.
  • Some bug fixes.
  • A New Improved music player - wx media player - plays in the terminal and even though you can see progress in conky - can be used on it's own. Written in bash and lua - very light and can handle huge number of tracks - uses mplayer as backend.
  • Multiple sites supported to get options for current and forecast weather
  • Type conkywx --help in a terminal window after installation to see improved help on a web browser.

NOTE:
  • To start - after conkywx installation - run conkywx --help in a terminal window - you should get conkywx help in a browser - now move your mouse over the USAGE menu and select GETTING STARTED - read this section - this will get you going.
  • As many users are using various conky variants - conky is no longer a dependency but however - conky is still required. Please ensure conky - in what ever form - is in fact installed.
  • To get the best out of conkywx - please install lua support for your conky - this could mean installing conky-all - check your distro.
  • In some cases to have conky restart automatically you may need to give a sleep 30 - delay in your conky-start script
  • Depending on your Perl installation - only Text::Wrap is the external module used - which should be part of Perl core installation. Modules for reading xml and json files are included with conkywx. wxDate is home grown, wxZone and wxStrftime are based on earlier work - improved for conkywx.
  • Many of you may find the text in templates out of spec - before you rip things apart - change the font value in the config section of the conky config file for the template. 
  • If you have questions etc you can get a lot of help at this ubuntu forum. Just go to the last page and post your issue.


    conkywx SIX
    conkywx SIX
    conkywx SIX
    conkywx SIX


    Distro File Location
    Arch linux AUR
    Debian based Ubuntu, Mint etc Debian Build
    RPM based Red Hat, Fedora, CentOS, Suse, etc RPM Build
    Stand Alone version you can run in your home directory Stand Alone Version
    Download fonts for the VinDSL Templates - has the installer in the archive VinDSL Template fonts

    For this stand alone version run the conkywx_fonts_assistant.sh file to install or remove conkywx fonts.

    People - feedback from you would be great ;-)


Saturday, November 21, 2015

Conkywx FIVE release

There is a newer version: conkywx SIX

Now Conkywx is FIVE - Additions and changes:
  • conky version 1.10x RECOMMENDED though will work with conky 1.09x as well
  • Huge changes to get things to work with conky 1.10x
  • Most short comings of this version of conky are handled using lua scripts
  • conky_startup - this handles the startup issues - if your update interval is 5 seconds - conky updates that conky config in 5 * 2 seconds [10 seconds ] - so we update it such that your conky starts like on steroids
  • conky_pre_exec - this handles anything that needs to be done only ONCE - or unless updated manually - same as 1.9x
  • conky_if_running - checks the pidof the required process - same as 1.9x
  • conky_top_name - handles the top process for the AUR versions
  • All templates modified to work with both conky versions
  • Earth quake/ Seismic has new options to set Alarms that will show up alarms via the conkywx system, the location in question also flashes in the Seismic display
  • Seconday PWS for xml_ID - when the primary stops or has stale data.
  • Some forecast handling changes.
  • Some bug fixes.
  • A New music player - wx media player - plays in the terminal and even though you can see progress in conky - can be used on it's own. Written in bash and lua - very light and can handle huge number of tracks - uses mplayer as backend.
  • Multiple sites supported to get options for current and forecast weather
  • Type conkywx --help in a terminal window after installation to see improved help on a web browser.

NOTE:
  • As many users are using various conky variants - conky is no longer a dependency but however - conky is still required. Please ensure conky - in what ever form - is in fact installed. 
  • To get the best out of conkywx - please install lua support for your conky - this could mean installing conky-all - check your distro.
  • In some cases to have conky restart automatically you may need to give a sleep 30 - delay in your conky-start script
  • Depending on your Perl installation - you may require extra modules - Time::Piece and HTML::Entities are hot favourites ;-)
  • Many of you may find the text in templates out of spec - before you rip things apart - change the xftfont value in the rc file for the template.


    conkywx FIVE
    conkywx FIVE


    Distro File Location
    There is a newer conkywx version: conkywx SIX
    Arch linux AUR
    Debian based Ubuntu, Mint etc Debian Build
    RPM based Red Hat, Fedora, CentOS, Suse, etc RPM Build
    Stand Alone version you can run in your home directory Stand Alone Version
    Download fonts for the VinDSL Templates - has the installer in the archive VinDSL Template fonts

    For this stand alone version run the conkywx_fonts_assistant.sh file to install or remove conkywx fonts.

    People - feedback from you would be great ;-)


Friday, July 03, 2015

Conkywx FOUR release

For the latest version of conkywx - click here
Now Conkywx is FOUR - Additions and changes:
  • Satellite images for storms and wind patterns
  • Earth quake/ Seismic data world wide. Multiple locations can be set to watch, set alarm magnitude and more... 
  • New Pollen data where available.
  • New UV data site independent - based on your Position and elevation in conkywx config file. Data obtained from ESA / TEMIS refer to conkywx help
  • Tides
  • New design for Anemometer and Barometer
  • New Clock with many styles and option.
  • The algorithms for data extrapolation have been completely re-written.
  • Menu driven help.
  • METAR data is internally translated with module integrated into magellan - the astronomy module.
  • New aircraft pointers for the Wind Vane.
  • Multiple sites supported to get options for current and forecast weather
  • Type conkywx --help in a terminal window after installation to see improved help on a web browser.

NOTE:
  • This version does not support conky 1.10x. There is no conky version 1.10x with cairo bindings at present. Suggest you stay with 1.9x series. If you are not using lua then the latest conky 1.10.0-2 should work - you will need to change the config files to the new lua format.
  • Due to changes in AUR - have included a pre-compiled package as well as a PKGBUILD file - take your pick ;-) 
  • As many users are using various conky variants - conky is no longer a dependency but however - conky is still required. Please ensure conky - in what ever form - is in fact installed. 
  • To get the best out of conkywx - please install lua support for your conky - this could mean installing conky-all - check your distro.
  • In some cases to have conky restart automatically you may need to give a sleep 30 - delay in your conky-start script
  • Depending on your Perl installation - you may require extra modules - Time::Piece and HTML::Entities are hot favourites ;-)
  • Many of you may find the text in templates out of spec - before you rip things apart - change the xftfont value in the rc file for the template.


    conkywx FOUR conkywx FOUR
    conkywx FOUR
  • The third image has a radar sweep on the clock - the hour and minute are the targets - and they glow with each sweep ;-)


  • Distro File Location
    Arch linux compiled package
    use "sudo pacman -U package name" to install
    Arch_Linux_package
    Arch linux PKGBUILD file
    use "makepkg -p ./PKGBUILD" then install the package as above in compiled version
    Arch_Linux_PKGBUILD
    Arch linux AUR
    Arch_Linux_AUR
    Debian based Ubuntu, Mint etc Debian Build
    RPM based Red Hat, Fedora, CentOS, Suse, etc RPM Build
    Stand Alone version you can run in your home directory Stand Alone Version
    Download fonts for the VinDSL Templates - has the installer in the archive VinDSL Template fonts

    For this stand alone version run the conkywx_fonts_assistant.sh file to install or remove conkywx fonts.

    People - feedback from you would be great ;-)


Thursday, April 23, 2015

Conkywx update info msn fix #2

Here is the FIX for msn.com

FIX::
File: conkywx.pl - line: 1274 or there about - in sub cleanuphtml {

$cntrA = get_arr_line_num( '<div class="current-info">' );
Line 1274 -> $cntrB = get_arr_line_num( '<section class="df">' );
change to -> $cntrB = get_arr_line_num( 'data-aop="DailyForecast"' );

replace '<section class="df">'  with 'data-aop="DailyForecast"'

and you should be good to go :-)

cheers

Wednesday, January 21, 2015

Conkywx update info

If you are using msn weather and getting error NA etc

    elsif ( $fct_stn eq "msn" ) {
        foreach (@fctfile) {
            chomp;
            if ( m{\s*aria-label="The forecast for (.*?) is (.*?). High of (.*?)&#176; and low of (.*?)&#176;.">.*} ) {
                $cnt++ ;


in conkywx.pl on line 1855 - remove the three characters highlighted above.

Wednesday, January 14, 2015

Conkywx THREE Released - Conkywx Conky Weather Script


For the latest version of conkywx - click here


Now Conkywx is THREE - Additions and changes:
  • Satellite images for storms and wind patterns
  • Multiple sites supported to get options for current and forecast weather
  • Type conkywx --help in a terminal window after installation to see improved help on a web browser.

NOTE:
  • As many users are using various conky variants - conky is no longer a dependency but however - conky is still required. Please ensure conky - in what ever form - is in fact installed. 
  • To get the best out of conkywx - please install lua support for your conky - this could mean installing conky-all - check your distro.
  • In some cases to have conky restart automatically you may need to give a sleep 30 - delay in your conky-start script
  • Depending on your Perl installation - you may require extra modules - Time::Piece and HTML::Entities are hot favourites ;-)
  • Many of you may find the text in templates out of spec - before you rip things apart - change the xftfont value in the rc file for the template.

    conkywx TWO

    conkywx TWO


    For this stand alone version run the conkywx_fonts_assistant.sh file to install or remove conkywx fonts.

People - feedback from you would be great ;-)


Tuesday, April 29, 2014

Conkywx TWO Released - Conkywx Conky Weather Script